Школа Linux

Ищи, здесь еще очень много интересного:


Наконец вышел драйвер для GDI принтеров фирмы Canon

Очень многие пользователи операционной системы linux, встречались с проблемой подключения принтеров фирмы Canon. Так как сама фирма драйверов GDI принтеров для linux так и не выпустила. А для разработчиков Linux протокол закрытый, вот поэтому и назрела проблема выпуска данного драйвера.

И наконец все таки вышла первая, хотя не совсем работоспособная версия данного драйвера для принтеров Canon серии LBP. Данный драйвер отличается "легкостью", совершенно не нужны демоны, которые должны запускаться при старте системы, и не мешает работе других подключенных принтеров.

Главным условием, для того, чтобы принтер заработал, посмотреть решение проблемы на compexpert.com.ua, а дальше необходимо при установке выбрать интерфейс не USB, а CAPT. Так же необходим правильный файл ppd (для информации: в данном файлике, прописаны все особенности принтера, описан низкоуровневый протокол), ьез правильного файла принтер скорее всего будет печатать, но качество печати будет желать лучшего.

В данный момент проверено несколько моделей принтеров, одним из которых является Canon LBP-2900.

Ну и напоследок несколько недоработок, которые будут исправляться по ходу:

- драйвер не поддерживает проверки наличия бумаги в лотке.
- если вы печатаете больше чем одну страницу, то возможно напечатается только первая.
- если страница, отправленная на печать является "сложной", возможен случай, когда память принтера переполняется и печатается страница не полностью.

Ну если отбросить все эти недочеты, - это все таки прорыв.



Related news items:
Newer news items:
Older news items:

 

Авторизация



Наши друзья

Теги



Последние комментарии